Mi cPanel no se carga o me desconecta después de habilitar Cloudflare

Síntoma:
Cuando intenta acceder al cPanel situado detrás de Cloudflare y descubre que la primera vez que carga la página, no se cargan las imágenes (o las hojas de estilo o JavaScript), y que cuando intenta acceder a cualquier enlace, se desconecta de inmediato. Parece como si cPanel no funcionara.

Motivo: 
cPanel tiene una opción denominada «Validación de IP de cookies». Esta configuración comprueba que la dirección IP de la que procedía originalmente el visitante, coincida con la dirección IP en las solicitudes posteriores. Con Cloudflare, la dirección IP de las solicitudes a su servidor puede proceder de cualquier dirección IP de la lista en https://www.cloudflare.com/ips.

Solución:

La solución consiste en acceder al servidor cPanel en una dirección URL que no redirija mediante proxy a través de Cloudflare. Utilice la dirección URL del subdominio proxy de cPanel http://cpanel.domain.com y haga que el DNS apunte directamente al servidor cPanel, la cual es una configuración de DNS predeterminada.
Asegúrese de que este subdominio no se redirija mediante proxy a través de Cloudflare (que la nube no sea naranja).

Nota: A partir de la versión 64 de WHM, esto ya no es un problema. No obstante, es posible que, en ciertas condiciones, todavía se produzca este problema. Si este es el caso, recurra a la solución anterior.

Para obtener más información, póngase en contacto con el proveedor de alojamiento o, si todavía tiene problemas, con el equipo de asistencia de cPanel.

 

¿No has encontrado una respuesta satisfactoria?

Nuestra herramienta de búsqueda puede contestar el 95% de las preguntas más comunes y es la mejor manera de conseguir una respuesta rápida.

Tecnología de Zendesk